Imported Debian patch 0.12.7-3
[bowtie.git] / debian / patches / use-dpkg-buildflags.patch
diff --git a/debian/patches/use-dpkg-buildflags.patch b/debian/patches/use-dpkg-buildflags.patch
new file mode 100644 (file)
index 0000000..146fe49
--- /dev/null
@@ -0,0 +1,17 @@
+Description: Use build flags from environment (dpkg-buildflags).
+ Necessary for hardening flags.
+Author: Simon Ruderich <simon@ruderich.org>
+Last-Update: 2012-04-24
+Bug-Closed: http://bugs.debian.org/670230
+
+--- bowtie-0.12.7.orig/Makefile
++++ bowtie-0.12.7/Makefile
+@@ -177,7 +177,7 @@
+   cat $^ | md5sum | awk '{print $$1}' > .$@.md5
+ endef
+-ALL_FLAGS=$(EXTRA_FLAGS) $(CFLAGS) $(CXXFLAGS)
++ALL_FLAGS=$(EXTRA_FLAGS) $(CPPFLAGS) $(CFLAGS) $(CXXFLAGS) $(LDFLAGS)
+ DEBUG_DEFS = -DCOMPILER_OPTIONS="\"$(DEBUG_FLAGS) $(ALL_FLAGS)\""
+ RELEASE_DEFS = -DCOMPILER_OPTIONS="\"$(RELEASE_FLAGS) $(ALL_FLAGS)\""