Merge branch 'master' into debianized
[htsworkflow.git] / setup.py
index 2229ed6b023ede2c73a331889cb79c8263311e12..0c1a203d01999d2c8af669aae16642d8012ca768 100644 (file)
--- a/setup.py
+++ b/setup.py
@@ -1,26 +1,39 @@
 from setuptools import setup
+from version import get_git_version
 
 setup(
-  name="gaworkflow",
-  description="some bots and other utilities to help deal with data from an illumina sequencer",
-  author="Diane Trout & Brandon King",
-  author_email="diane@caltech.edu",
-  packages=["gaworkflow", 
-            "gaworkflow.pipeline",
-            "gaworkflow.frontend",
-            "gaworkflow.frontend.fctracker",
-            "gaworkflow.frontend.eland_config"           
-             ],
-  scripts=[
-        'scripts/configure_pipeline',
-        'scripts/copier',
-        'scripts/gerald2bed.py',
-        'scripts/library.py',
-        'scripts/makebed',
-        'scripts/spoolwatcher', 
-        'scripts/rerun_eland.py',
-        'scripts/retrieve_config',
-        'scripts/runfolder',
-        'scripts/runner',
+    name="htsworkflow",
+    version=get_git_version(),
+    description="Utilities to help manage high-through-put sequencing",
+    author="Diane Trout, Brandon King",
+    author_email="diane@caltech.edu",
+    packages=["htsworkflow", 
+              "htsworkflow.automation",
+              "htsworkflow.pipelines",
+              "htsworkflow.util",
+              # django site
+              "htsworkflow.frontend",
+              "htsworkflow.frontend.analysis",
+              "htsworkflow.frontend.eland_config",
+              "htsworkflow.frontend.experiments",
+              "htsworkflow.frontend.inventory",
+              "htsworkflow.frontend.reports",
+              "htsworkflow.frontend.samples",
+              ],
+    scripts=[
+        "scripts/htsw-copier",
+        "scripts/htsw-eland2bed",
+        "scripts/htsw-elandseq",
+        "scripts/htsw-gerald2bed",
+        "scripts/htsw-get-config",
+        "scripts/htsw-qseq2fastq",
+        "scripts/htsw-record-runfolder",
+        "scripts/htsw-runfolder",
+        "scripts/htsw-runner",
+        "scripts/htsw-spoolwatcher",
+        "scripts/htsw-srf",
+        "scripts/htsw-srf2fastq",
+        "scripts/htsw-update-archive",
+        "scripts/htsw-validate",
         ],
-)
+    )