Patched the example makefile to not use samtools pileup, deprecated.
[samtools.git] / debian / rules
index 3605b20bc981cf33522c4e01119f03acea2a3bd0..d6d4267cbfce61ec4091a4dcf229af7028cd4df6 100755 (executable)
@@ -2,6 +2,7 @@
 
 include /usr/share/cdbs/1/rules/debhelper.mk
 include /usr/share/cdbs/1/class/makefile.mk
+include /usr/share/cdbs/1/rules/patchsys-quilt.mk
 
 CFLAGS += -fPIC
 
@@ -15,6 +16,7 @@ clean::
 
 binary-install/samtools::
        install -m 644 bcftools/README $(CURDIR)/debian/samtools/usr/share/doc/samtools/README.bcftools
+       ln -s samtools.1.gz $(CURDIR)/debian/samtools/usr/share/man/man1/bcftools.1.gz
 
 binary-fixup/samtools::
        sed -i 's|^#!/software/bin/python|#!/usr/bin/python|' $(CURDIR)/debian/samtools/usr/share/samtools/varfilter.py