switch to using boost::filesystem
[mussa.git] / alg / test / CMakeLists.txt
index ecbd3aa6c1384465882c3f2e5a4afdc6b624681c..3e1e43b27e29e6c24909ff365b4babd720e03eaa 100644 (file)
@@ -2,11 +2,18 @@ SET(SOURCES test_annotation_color.cpp test_color.cpp test_conserved_path.cpp
             test_flp.cpp test_glseqbrowser.cpp test_glsequence.cpp
             test_main.cpp test_mussa.cpp test_nway.cpp test_sequence.cpp)
 
+# dont you love the number of \ you need to make sure the " shows up in
+# the C compiler?
+SET(EXAMPLE_DIR ${CMAKE_SOURCE_DIR}/examples)
+SET_SOURCE_FILES_PROPERTIES(${SOURCES} 
+                           COMPILE_FLAGS "-DEXAMPLE_DIR=\\\"${EXAMPLE_DIR}\\\""
+                           )
+
 FIND_PACKAGE(OpenGL)
 INCLUDE(FindBoost)
 
 ADD_EXECUTABLE(unittest ${SOURCES})
-ADD_TEST(core_test ${EXECUTABLE_OUTPUT_PATH}/alg/test/unittest)
+ADD_TEST(core_test ${CMAKE_BINARY_DIR}/alg/test/unittest)
 LINK_DIRECTORIES(${MUSSA_BINARY_DIR}/alg})
 TARGET_LINK_LIBRARIES(unittest 
                         ${BOOST_UNIT_TEST_LIB}