Need boost system for Python build in Boost 1.40.
[mussa.git] / py / CMakeLists.txt
index cb793e1ec59772cd6240beab159d41ae0cf0239e..0e0848816cfeecd013ca8d276654595fb04e8a93 100644 (file)
@@ -1,3 +1,5 @@
+set(Boost_USE_STATIC_LIBS   ON)
+set(Boost_USE_MULTITHREADED ON)
 FIND_PACKAGE(Boost 1.34.1 COMPONENTS python filesystem serialization)
 FIND_PACKAGE(OpenGL)
 FIND_PACKAGE(PythonLibs)
@@ -36,6 +38,7 @@ IF(Boost_PYTHON_LIBRARY)
   SET(MUSSA_LIBRARIES
         mussa_core
         ${Boost_PYTHON_LIBRARY}
+       ${Boost_SYSTEM_LIBRARY}
         ${Boost_FILESYSTEM_LIBRARY}
         ${Boost_SERIALIZATION_LIBRARY}
         ${OPENGL_gl_LIBRARY}