Update mussa to build on ubuntu 10.04 with qt 4.6.2 +boost 1.40.0.1
[mussa.git] / py / CMakeLists.txt
index cb793e1ec59772cd6240beab159d41ae0cf0239e..dbfdb2d3c4e3ae0974b6063dcbe6e443c532425e 100644 (file)
@@ -1,3 +1,5 @@
+set(Boost_USE_STATIC_LIBS   OFF)
+set(Boost_USE_MULTITHREADED ON)
 FIND_PACKAGE(Boost 1.34.1 COMPONENTS python filesystem serialization)
 FIND_PACKAGE(OpenGL)
 FIND_PACKAGE(PythonLibs)
@@ -36,6 +38,7 @@ IF(Boost_PYTHON_LIBRARY)
   SET(MUSSA_LIBRARIES
         mussa_core
         ${Boost_PYTHON_LIBRARY}
+        ${Boost_SYSTEM_LIBRARY}
         ${Boost_FILESYSTEM_LIBRARY}
         ${Boost_SERIALIZATION_LIBRARY}
         ${OPENGL_gl_LIBRARY}