add prototype wrapping of the qt sequence browser
[mussa.git] / py / test / CMakeLists.txt
index e189ec94884410660c107d1016aa3f576688505f..15c679910f4a88d2899acac1e4b70ef845315467 100644 (file)
@@ -15,17 +15,20 @@ SET_SOURCE_FILES_PROPERTIES(
 
 ADD_EXECUTABLE(mussa_python_test ${SOURCES})
 ADD_TEST(mussa_python_test ${CMAKE_BINARY_DIR}/py/test/mussa_python_test)
-LINK_DIRECTORIES(${MUSSA_BINARY_DIR}/alg})
+LINK_DIRECTORIES(${CMAKE_BINARY_DIR}/alg})
+# Really it is important to go from library with the most dependencies to least
 TARGET_LINK_LIBRARIES(mussa_python_test
-                        mussa_core
                         mussa_qui
                         mussa_py
-                        ${QT_LIBRARIES}
+                        mussa_core
+                        ${QT_QTCORE_LIBRARY}
                         ${OPENGL_gl_LIBRARY}
                         ${BOOST_PROGRAM_OPTIONS_LIBRARY}
                         ${BOOST_FILESYSTEM_LIBRARY}
+                        ${BOOST_SERIALIZATION_LIBRARY}
                         ${BOOST_PYTHON_LIBRARY}
                         ${PYTHON_LIBRARIES}
+                        ${PYTHON_LINK_LIBRARIES}
                         ${BOOST_UNIT_TEST_LIBRARY} 
                         )