Extend the python mussa interface.
[mussa.git] / py / test / CMakeLists.txt
index b54468b44c4b1c53688ddc036384149cb5d4b7de..2cf195124ee643183e236e8b11b931a008492292 100644 (file)
@@ -1,6 +1,6 @@
 FIND_PACKAGE(PythonLibs)
 
-INCLUDE(FindBoost)
+FIND_PACKAGE(Boost 1.34.1 COMPONENTS program_options filesystem serialization python unit_test_framework )
 INCLUDE(Platform)
 
 SET(SOURCES test_python.cpp )
@@ -21,15 +21,15 @@ TARGET_LINK_LIBRARIES(mussa_python_test
                         mussa_qui
                         mussa_py
                         mussa_core
-                        ${QT_LIBRARIES}
+                        ${QT_QTCORE_LIBRARY}
                         ${OPENGL_gl_LIBRARY}
-                        ${BOOST_PROGRAM_OPTIONS_LIBRARY}
-                        ${BOOST_FILESYSTEM_LIBRARY}
-                        ${BOOST_SERIALIZATION_LIBRARY}
-                        ${BOOST_PYTHON_LIBRARY}
+                        ${Boost_PROGRAM_OPTIONS_LIBRARY}
+                        ${Boost_FILESYSTEM_LIBRARY}
+                        ${Boost_SERIALIZATION_LIBRARY}
+                        ${Boost_PYTHON_LIBRARY}
                         ${PYTHON_LIBRARIES}
                         ${PYTHON_LINK_LIBRARIES}
-                        ${BOOST_UNIT_TEST_LIBRARY} 
+                        ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY} 
                         )
 
 SET_TARGET_PROPERTIES(