Switch to a new FindBoost
[mussa.git] / py / test / CMakeLists.txt
index 15c679910f4a88d2899acac1e4b70ef845315467..62fc91df210f0b80fd90cba43e6354e28e809ca2 100644 (file)
@@ -1,6 +1,6 @@
 FIND_PACKAGE(PythonLibs)
 
-INCLUDE(FindBoost)
+FIND_PACKAGE(Boost 1.34.1 COMPONENTS program_options filesystem serialization python2.3 unit_test_framework )
 INCLUDE(Platform)
 
 SET(SOURCES test_python.cpp )
@@ -23,13 +23,13 @@ TARGET_LINK_LIBRARIES(mussa_python_test
                         mussa_core
                         ${QT_QTCORE_LIBRARY}
                         ${OPENGL_gl_LIBRARY}
-                        ${BOOST_PROGRAM_OPTIONS_LIBRARY}
-                        ${BOOST_FILESYSTEM_LIBRARY}
-                        ${BOOST_SERIALIZATION_LIBRARY}
-                        ${BOOST_PYTHON_LIBRARY}
+                        ${Boost_PROGRAM_OPTIONS_LIBRARY}
+                        ${Boost_FILESYSTEM_LIBRARY}
+                        ${Boost_SERIALIZATION_LIBRARY}
+                        ${Boost_PYTHON_LIBRARY}
                         ${PYTHON_LIBRARIES}
                         ${PYTHON_LINK_LIBRARIES}
-                        ${BOOST_UNIT_TEST_LIBRARY} 
+                        ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY} 
                         )
 
 SET_TARGET_PROPERTIES(