Switch to a new FindBoost
[mussa.git] / py / test / CMakeLists.txt
index bf03795f88203d4aa8b7290492c3c4bd954d77eb..62fc91df210f0b80fd90cba43e6354e28e809ca2 100644 (file)
@@ -1,6 +1,6 @@
 FIND_PACKAGE(PythonLibs)
 
-INCLUDE(FindBoost)
+FIND_PACKAGE(Boost 1.34.1 COMPONENTS program_options filesystem serialization python2.3 unit_test_framework )
 INCLUDE(Platform)
 
 SET(SOURCES test_python.cpp )
@@ -16,18 +16,20 @@ SET_SOURCE_FILES_PROPERTIES(
 ADD_EXECUTABLE(mussa_python_test ${SOURCES})
 ADD_TEST(mussa_python_test ${CMAKE_BINARY_DIR}/py/test/mussa_python_test)
 LINK_DIRECTORIES(${CMAKE_BINARY_DIR}/alg})
+# Really it is important to go from library with the most dependencies to least
 TARGET_LINK_LIBRARIES(mussa_python_test
-                        mussa_core
                         mussa_qui
                         mussa_py
-                        ${QT_LIBRARIES}
+                        mussa_core
+                        ${QT_QTCORE_LIBRARY}
                         ${OPENGL_gl_LIBRARY}
-                        ${BOOST_PROGRAM_OPTIONS_LIBRARY}
-                        ${BOOST_FILESYSTEM_LIBRARY}
-                        ${BOOST_SERIALIZATION_LIBRARY}
-                        ${BOOST_PYTHON_LIBRARY}
+                        ${Boost_PROGRAM_OPTIONS_LIBRARY}
+                        ${Boost_FILESYSTEM_LIBRARY}
+                        ${Boost_SERIALIZATION_LIBRARY}
+                        ${Boost_PYTHON_LIBRARY}
                         ${PYTHON_LIBRARIES}
-                        ${BOOST_UNIT_TEST_LIBRARY} 
+                        ${PYTHON_LINK_LIBRARIES}
+                        ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY} 
                         )
 
 SET_TARGET_PROPERTIES(