Switch to a new FindBoost
[mussa.git] / py / test / CMakeLists.txt
index e2e3896b24c6132c70d44eea0e62606e4c0c01f3..62fc91df210f0b80fd90cba43e6354e28e809ca2 100644 (file)
@@ -1,6 +1,6 @@
 FIND_PACKAGE(PythonLibs)
 
-INCLUDE(FindBoost)
+FIND_PACKAGE(Boost 1.34.1 COMPONENTS program_options filesystem serialization python2.3 unit_test_framework )
 INCLUDE(Platform)
 
 SET(SOURCES test_python.cpp )
@@ -21,15 +21,15 @@ TARGET_LINK_LIBRARIES(mussa_python_test
                         mussa_qui
                         mussa_py
                         mussa_core
-                        ${QT_LIBRARIES}
+                        ${QT_QTCORE_LIBRARY}
                         ${OPENGL_gl_LIBRARY}
-                        ${BOOST_PROGRAM_OPTIONS_LIBRARY}
-                        ${BOOST_FILESYSTEM_LIBRARY}
-                        ${BOOST_SERIALIZATION_LIBRARY}
-                        ${BOOST_PYTHON_LIBRARY}
+                        ${Boost_PROGRAM_OPTIONS_LIBRARY}
+                        ${Boost_FILESYSTEM_LIBRARY}
+                        ${Boost_SERIALIZATION_LIBRARY}
+                        ${Boost_PYTHON_LIBRARY}
                         ${PYTHON_LIBRARIES}
-                        ${BOOST_UNIT_TEST_LIBRARY} 
-                        util
+                        ${PYTHON_LINK_LIBRARIES}
+                        ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY} 
                         )
 
 SET_TARGET_PROPERTIES(