Reorder libraries for win32
[mussa.git] / py / test / CMakeLists.txt
index bf03795f88203d4aa8b7290492c3c4bd954d77eb..aa0984261b05f16a794a2ff0226eff39471d7124 100644 (file)
@@ -16,10 +16,11 @@ SET_SOURCE_FILES_PROPERTIES(
 ADD_EXECUTABLE(mussa_python_test ${SOURCES})
 ADD_TEST(mussa_python_test ${CMAKE_BINARY_DIR}/py/test/mussa_python_test)
 LINK_DIRECTORIES(${CMAKE_BINARY_DIR}/alg})
+# Really it is important to go from library with the most dependencies to least
 TARGET_LINK_LIBRARIES(mussa_python_test
-                        mussa_core
                         mussa_qui
                         mussa_py
+                        mussa_core
                         ${QT_LIBRARIES}
                         ${OPENGL_gl_LIBRARY}
                         ${BOOST_PROGRAM_OPTIONS_LIBRARY}