IsFileValidator doesn't use signal/slots
[mussa.git] / qui / CMakeLists.txt
index 5e89814db6e14515e5e21b250d559ceefbd0f900..53c9457d1c736450b05520f636b3f8758f88b798 100644 (file)
@@ -26,7 +26,7 @@ SET(MOC_HEADERS
       motif_editor/MotifModel.hpp
       motif_editor/MotifEditor.hpp
       motif_editor/MotifEditorDelegate.hpp
-      mussa_setup_dialog/IsFileValidator.hpp
+      mussa_setup_dialog/IsFileValidator.hpp
       mussa_setup_dialog/MussaSetupDialog.hpp
       mussa_setup_dialog/MussaSetupWidget.hpp
       mussa_setup_dialog/SequenceSetupFrame.hpp
@@ -40,6 +40,8 @@ SET(MOC_HEADERS
       seqbrowser/seqproperties/PropertiesWindow.hpp
       subanalysis/SequenceLocationModel.hpp
       subanalysis/SubanalysisWindow.hpp
+      threading/GuiProxy.hpp
+      threading/InterpreterThread.hpp
     )
 SET(GUI_SOURCES 
       ImageSaveDialog.cpp      
@@ -68,6 +70,9 @@ SET(GUI_SOURCES
       seqbrowser/seqproperties/PropertiesWindow.cpp
       subanalysis/SequenceLocationModel.cpp
       subanalysis/SubanalysisWindow.cpp
+      threading/GuiProxy.cpp
+      threading/InterpreterThread.cpp
+      threading/ThreadManager.cpp
      )
 SET(PY_SOURCES ../py/python.cpp)
 SET(RCCS ../icons.qrc)