Fix upstream makefile to enable hardening flags as well use debhelper 9 to support...
[tabix.git] / debian / patches / use-dpkg-buildflags.patch
diff --git a/debian/patches/use-dpkg-buildflags.patch b/debian/patches/use-dpkg-buildflags.patch
new file mode 100644 (file)
index 0000000..7856be7
--- /dev/null
@@ -0,0 +1,11 @@
+--- tabix.orig/Makefile
++++ tabix/Makefile
+@@ -12,7 +12,7 @@
+ .SUFFIXES:.c .o
+ .c.o:
+-              $(CC) -c $(CFLAGS) $(DFLAGS) $(INCLUDES) $< -o $@
++              $(CC) -c $(CPPFLAGS) $(CFLAGS) $(CXXFLAGS) $(DFLAGS) $(LDFLAGS) $(INCLUDES) $< -o $@
+ all-recur lib-recur clean-recur cleanlocal-recur install-recur:
+               @target=`echo $@ | sed s/-recur//`; \