don't link against X11 on OS X
[mussa.git] / alg / test / CMakeLists.txt
index 7e5b7a89f87127a0248e08a330a390cd64839f71..607b9e9e79bdd5b7892b305c2dd171945867451b 100644 (file)
@@ -1,5 +1,7 @@
 FIND_PACKAGE(OpenGL)
 INCLUDE(FindBoost)
+FIND_PACKAGE(Qt4)
+INCLUDE( ${QT_USE_FILE} )
 INCLUDE(Platform)
 
 SET(SOURCES 
@@ -34,7 +36,8 @@ ADD_EXECUTABLE(unittest ${SOURCES})
 ADD_TEST(core_test ${CMAKE_BINARY_DIR}/alg/test/unittest)
 LINK_DIRECTORIES(${CMAKE_BINARY_DIR}/alg})
 TARGET_LINK_LIBRARIES(unittest 
-                        mussa_core 
+                        mussa_core
+                        ${QT_LIBRARIES}
                         ${BOOST_FILESYSTEM_LIBRARY}
                         ${BOOST_UNIT_TEST_LIBRARY} 
                         ${BOOST_SERIALIZATION_LIBRARY}