provide python interpreter for mussa qui via a seperate thread
[mussa.git] / py / CMakeLists.txt
index 00a18b5969a069f2699c6c70874cc8cfcea81eaf..869faad95388fed5f2384c858d1470ed8c13a210 100644 (file)
@@ -21,9 +21,13 @@ IF(BOOST_PYTHON_LIBRARY)
         nway_paths.cpp
         sequence.cpp
         )
-  
+  SET(QUI_SOURCES
+    module_qui.cpp
+    MussaWindow.cpp
+  )
   ADD_LIBRARY(mussa MODULE ${SOURCES})
   ADD_LIBRARY(mussa_py STATIC ${SOURCES})
+  ADD_LIBRARY(mussa_qui_py STATIC ${QUI_SOURCES})
   # Any suggestions for a more elegant solution to this? -diane
   IF(WIN32)
     ADD_CUSTOM_TARGET(mussa.dll ALL
@@ -53,7 +57,7 @@ IF(BOOST_PYTHON_LIBRARY)
     COMPILE_FLAGS "${PY_CFLAGS}"
   )
   SET_TARGET_PROPERTIES(
-    mussa mussa_py PROPERTIES
+    mussa mussa_py mussa_qui_py PROPERTIES
     COMPILE_FLAGS "${PY_CFLAGS}"
     LINK_FLAGS "${PY_LDFLAGS}"
   )